New Format


Good you’re getting notifications.

There are 3 ways that you could potentially get a notification:

  1. a bubble on your user icon at the top
    17 PM

  2. desktop notification if you accepted the browser’s request to notify you directly

  3. emails

Anything outside of those 3 you’re noticing? @qixlqatl


Agreed. I don’t post much here anyway. I guess this will mean that I do so even less.


My initial reaction is not favorable. Looks to me like an attempt to make one size fit all. But then what the heck do I know?

Also appears that I am logged in but I did not do so. How does that happen? Now to go and see if I can figure out how to make a post and then log out.


I think it’s (the weirdness, that is) Tapatalk? It’s supposed to be working with RO. Just found an email notification for this post in spam, and moved it to inbox, so e-mail notifications are working. I haven’t seen anything from the browser (using chrome) asking for direct notification authority. I do get the icon notifications ( I have 2 right now).


@qixlqatl I haven’t tried Tapatalk, thanks for letting me know I’ll give it a whirl


You covered it pretty well. However, I have a problem with the fact there are only two generic headings with sub headings and topics randomly " organized" under the two headings - “Popular” and “Recent”. Not as user friendly as the old format - at least not to my mind’s eye. Oh well, I’m sure you had your reasons for going with this format.


This new format does take some getting used to but as far as a SW and security standpoint, it is a lot better than the old SW that RO was using.

I too am having to get to “know” this new SW but that will come with some time.



First, thanks for the info on the front page blogs. I’m assuming you will PM us when the migration is done. Know you have a lot to do, but can you make a time estimate?

Now, I know you are trying to make the site more secure, and are making all these changes in good faith . . . and are weathering all these criticisms (including mine), when I myself would just say, “Screw you guys, I’m trying to make things better for you, and if you don’t like it, kiss off.” . . . customer service not being one of my strong points.

Yes, I’m still pissed off, but am willing to give it a shot.

So, in that spirit, let me try to work with you, and rather than list my dislikes, I’ll just call it a “wish list” (the SW may already be able to do some of these things . . . I just haven’t figured it out yet.)

Now for a “wish list”:

  • First off, is there a tutorial on this board SW? (That may answer a lot of these issues.)

  • The old software had an “advanced” search function. You could use it to do a lot of things.

For example, if you remembered a “keyword” in one of your old posts, say “diplomat”, you could search all your old posts with that keyword, and the search results would list all your posts that contained “diplomat”. Likewise, if you remembered a keyword FROM SOMEBODY ELSE’S POST, you could find that post simply by entering the keyword AND the user (“I know XXX said this . . . where in the heck is that post?”)

Another example, you could leave the “keyword” field blank, and just fill in the “user” field (say, “RO_admin”), and the results would list ALL posts made by that user. This was particularly useful if you wanted to find out when that user last posted (“it’s been months since XXX posted . . . has anybody heard from him?”)

  • How do you insert images? (Yes, I know you need an image hosting site . . . but will the SW accept image tags, and in what syntax?)

  • Will the SW show the image inline, just the url, or at the end of the post as an attachment? (The old software would show the image in line by default.)

  • Same question with youtube videos . . . tags: {} = [] {VIDEO}url{/VIDEO}.

  • The old software had a wysiwyg posting window interface that would, in many cases, insert the proper tag. For example, there was a little “film strip” icon that when tapped would present a field to enter the youtube url, and it would insert the video in line.

  • Not a problem if the tags need to be entered manually (the wysiwyg was a lazy man’s way, but did save time on occasion), just need to know the syntax. HTML, BB code, or what?

  • On my tablet (Samsung Galaxy Tab S2), the software keyboard (“Hacker’s Keyboard”) pops up and obscures the posting window . . . and swiping to scroll doesn’t work. I can make it withdraw, but the minute I tap in the posting window, it pops up again. Obviously, I’ve figured out a workaround, but it’s clumsy and time consuming. Any suggestions, short of getting a physical keyboard? What am I missing here?

  • With the old software, you could tap on the post number and the url FOR THAT POST would show up in the browser address field. You could then c&p to point to that post. How do you do that with this SW?

As I climb this steep learning curve, I’m sure I’ll have a few revelations (“Oh, that’s how it works . . .”), but it would make the climb easier if you could point me to a tutorial.

Plus, I’m sure I’ll have more bullet item questions as I encounter more problems. A good tutorial would save us both a lot of time, and cut down on my frustation, and stop me from saying, “You can take your new software and shove it” (NO . . . just kidding. Wouldn’t say anything like that . . . would just leave.)



Well at least the emails look better (and actually get delivered!)

The formatting is nice there, better contrast


Hmmm, this is not how I intend it to be. What I see when I click on the RO logo in the top left or when I first visit the site is the following:

In this format there are the old categories listed on the left, similar to what it was previously. Clicking one of those sub-bullets like “Left vs Right” or “In the News” will take you to the list of posts in that category. And on the right is the list of the most recent post activity.

At the top there are also options for choosing to see posts by latest, unread, top (“popular”) and new (new replies for me):
42 PM


Wow, Thanks BobJam! I really appreciate the time it took for you to share this detailed feedback.

Approximately 2 weeks to get the old blog posts back up. I’m aiming for September 9th or 10th for the blog relaunch. I will PM you when that is done.

Yes, there are 2 tutorials. The basic features and the advanced features tutorial. I just pointed you to the basic one by PM. If anyone else would like to try the interactive tutorial please

  1. click this link and then click the “Message” button in the bottom left of that link
  2. Clicking the “Message” button will send a new PM to our robot friend and tutorial leader.
  3. Read the PM that the bot replies with. At the end of the PM it asks you to do something (like “reply to me”). Each subsequent reply will teach you to do new things and use new features, like adding photos or videos, how to format posts, how to like, bookmark, and flag spam and inappropriate content.

Allow me to break here and reply to the rest separately @BobJam


BobJam - I’ve tested these search scenarios, you can find the search button at the top of this forum near your user icon. The search icon looks like a magnifying glass. Clicking on it you’ll get the search page and an “Advanced” set of options below where you can specify a user that posted, or posts you’ve liked, that contain the words you’re looking for.

Perhaps as an example you could challenge me in another thread to find something you previously would find- and I’ll try to demonstrate how i did so.


Direct links to posts are found by clicking on the posted at timestamp of that post. The timestamp is in the top right corner of that individual post.

Sometimes that posted at timestamp will be a date like “Jul 11” other times it will be a relative time like “6h” saying the post was from 6 hours ago.


This is my biggest gripe. It has the potential to be a deal breaker.

I’m going to expand on one of the issues I identified in my “wish list”. To wit:

Lemme’ try some images to 'splain this better. This is what I first see when I go to reply to a thread or an individual post within a thread:

So far, so good. A blank posting window ready to go . . . unremarkable.

But then this happens:

and this:

My workaround?:

I can make the software keyboard go away (on this Samsung tablet, that’s pressing the “volume down” physical button), and then long press and get the “PASTE” pop up, and then paste the composed post from my text editor.

That’s actually what I do for any post that’s either lengthy or may require some thought.

But for quick, short, and simple replies, it’s much more efficient to just type the reply right into the posting window. I can’t do that.

This is a potential deal breaker.

However, it may not be the new board SW. It may either be my own failure, or just something unique to mobile devices (in which case, neither I, nor RO_admin, would be able to remedy.)

Other software I have locally does not do this, nor did the old board SW. For example, my M$ Excel performs nicely. If a cell I want to select is hidden behind the software keyboard, I simply collapse the keyboard, select the cell, and then the cell automatically scrolls up and the keyboard reappears just BELOW the selected cell.

I would have PM’d @RO_admin on this, but I chose to put this on the open forum because I know there are other users here with mobile devices. For example, I think @WhoIsJohnGalt uses an iPAD for posting. I’m wondering if he, or some other mobile device user, can tell me how to fix this.

On the off-chance it was the browser I was using (FireFox), I tried another . . . Chrome . . . and got the SAME behavior.

Also cleared the cache . . . TWICE . . . and still no joy.

What the heck am I doing wrong? (I’m hoping to have a real “duhhh . . .” moment, smack my forehead, and move on.)



I don’t even understand what you wrote above. Too many terms are used which I do not understand.



I agree completely!

I think the main problem is, one has to be a computer geek to fully understand the new format.


I see the problem. Thank you for the explanation and screenshots. Will get a fix on the way for this promptly. Usually 24-48 hour turnaround on this but maybe I can negotiate quicker development.


A few small changes are on the way to make things a little more easy


I just read your post @BobJam and so I logged on with my iPad using Firefox.

This is what happens on mine

My whole screen moves up. Not sure if @RO_admin fixed this yet or it is your type of tablet.


I don’t even see that and frankly I don’t have time for this.